FeedForAll Forum Index  
 Home  •  FAQ  •   Search   •  Register   •  Profile   •  Log in
 ERROR : rss2html-pro Call to undefined method baseParserClas View next topic
View previous topic
Post new topicReply to topic
Author Message
solarsurfer



Joined: 11 Jun 2013
Posts: 8

PostPosted: Wed Jun 12, 2013 3:12 am Reply with quoteBack to top

Hi.
When I use rss2html-pro i get a blank page when displaying the output, and this error in the log file.

[12-Jun-2013 08:53:42 Europe/London] PHP Fatal error: Call to undefined method baseParserClass::rootRSSParserClass_iT_TB_DC_ITMS() in /home1/dogsear1/public_html/rss1/html/FeedForAll_XMLParser.inc.php(1713) : eval()'d code on line 3

I am using PHP 5.3. I changed to 5.2 and got the same error .

Any ideas ?

I removed the pro version and then it works fine.

Any help would be appreciated.
Thanks
View user's profile
Tech Support



Joined: 27 Aug 2004
Posts: 2783

PostPosted: Wed Jun 12, 2013 9:21 am Reply with quoteBack to top

First this it to be sure you are running the most current rss2html and rss2htmlpro files.

You can download rss2html from here:
http://www.feedforall.com/download/rss2html.zip

and rss2htmlpro from here (you will need the username and password sent with your registration to access this one):
http://www.feedforall.com/scripts/rss2html-pro.zip

Make sure that all the files for both these downloads are in the same folder.
When you add the rss2htmlpro files into the same folder as rss2html.php, then rss2html.php gains the pro features. You don't actually run FeedForAll_rss2html_pro.php, you continue to run the rss2html.php file (a common mistake).

_________________
Create RSS Feeds
Audio Recording and Editing
View user's profile
solarsurfer



Joined: 11 Jun 2013
Posts: 8

PostPosted: Wed Jun 12, 2013 11:10 am Reply with quoteBack to top

Hi,
yea I still run rss2html as before, I sussed out that the pro script took over by default, so i run for example www.mysite.co.uk/rss2html.php and then fill in the relevant stuff. It reports all is well after compiling, but then the view page just gives a blank (die) screen.

If i take out the pro script from the dir, all works fine!
I also have a local test unbuntu server which i had to reduce the PHP to ver 5.3 in order to work, and the same error occurred. (I think, ill re-check this am)

I am using the mesh and filter scripts, so im passing the xml via a php file instead of a xml based file, but I think I have changed the configs to accept a php file as well as xml file, etc.

Ill try what you recommend and report back,
cheers and thanks for your help, its appreciated !

Solar
View user's profile
solarsurfer



Joined: 11 Jun 2013
Posts: 8

PostPosted: Wed Jun 12, 2013 11:21 am Reply with quoteBack to top

I cant find the "re-edit" previous posted button, so here goes.
Re my reply above,
The same prob occurred on the Unbuntu server, as in, the non pro version did run !, but the pro version did not. I have played with a few things today, so ill re-play with em once my head is fresher ! lol !
Cheers and thanks
View user's profile
Tech Support



Joined: 27 Aug 2004
Posts: 2783

PostPosted: Wed Jun 12, 2013 12:28 pm Reply with quoteBack to top

Try removing the following two files from the rss2html folder and see if you get better/different results.

FeedForAll_parse_ITMS.inc.php
FeedForAll_parse_iTunes.inc.php

_________________
Create RSS Feeds
Audio Recording and Editing
View user's profile
solarsurfer



Joined: 11 Jun 2013
Posts: 8

PostPosted: Thu Jun 13, 2013 2:21 am Reply with quoteBack to top

Hi
I had to move the following, but it is now working, or it seems to be, so ill throw some code at it today and see how it goes !

To recap I had to remove the following files :-

FeedForAll_parse_DublinCore.inc.php
FeedForAll_parse_ITMS.inc.php
FeedForAll_parse_iTunes.inc.php
FeedForAll_parse_TrackBack.inc.php


Thanks again for your help !
I did want to play with TrackBack, but now ill have to wait till i get the rest going !

Thanks again
View user's profile
solarsurfer



Joined: 11 Jun 2013
Posts: 8

PostPosted: Thu Jun 13, 2013 7:16 am Reply with quoteBack to top

Hi
further to my previous reply, it seems to work, but your example of pagination does not !
Shame, because I was wanting to use that bit of useful script

Regards
Solar
View user's profile
Display posts from previous:      
Post new topicReply to topic


 Jump to:   



View next topic
View previous topic


Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme