FeedForAll Forum Index  
 Home  •  FAQ  •   Search   •  Register   •  Profile   •  Log in
 WP insert image code does not display in ItemDescription View next topic
View previous topic
Post new topicReply to topic
Author Message
webfeatus



Joined: 12 May 2008
Posts: 23

PostPosted: Tue May 15, 2012 6:02 am Reply with quoteBack to top

Calling a standard WordPress rss feed into html.

Familiar with rss2html pro version.
Registered owner of FFA

I receive no image using ~~~ItemDescription~~~

I must use ~~~ItemContentEncoded~~~ to receive the post image.

http://www.3dminime-figurines-bobbleheads.com/articles/category/featured/feed/

WP code
Code:
<p><a href="http://www.3dminime-figurines-bobbleheads.com/articles/wp-content/uploads/2012/02/post-image.jpg"><img class="alignnone size-medium wp-image-284" title="post image" src="http://www.3dminime-figurines-bobbleheads.com/articles/wp-content/uploads/2012/02/post-image-247x300.jpg" alt="" width="247" height="300" /></a></p>


Can anyone help?
View user's profile
webfeatus



Joined: 12 May 2008
Posts: 23

PostPosted: Wed May 16, 2012 9:00 pm Reply with quoteBack to top

My security software shows a persistent warning because the script is managing an rss feed into index page html. So the warning appears every time someone visits the site.

[code]<table width="100%" class="bannertxt">
~~~BeginItemsRecord~~~
<?php
// Set initial values for our variables
$theImage = "&nbsp;"; // To ensure proper display with borders
$newDescription = "~~~ItemContentEncoded~~~";
$match = Array();

// Use regular expressions to find <img ... >
if (preg_match("/<img[^>]*>/", $newDescription, $match) !== FALSE) {
// Make sure it truely was a match
if ((count($match) != 0) && ($match[0] != "")) {
// Save the image
$theImage = $match[0];
}
}
?>

<tr>
<td width="600"><h1>~~~ItemTitle~~~</h1>
~~~ItemDescription~~~
</td>
<td width="403" align="center"><? echo $theImage ; ?></td>
</tr>
~~~EndItemsRecord~~~
</table>[/code]

I know why this is happening but I cannot work out a way to *not* call the "~~~ItemContentEncoded~~~" variable into the script that runs at: http://www.3dminime-figurines-bobbleheads.com/index.html (see section with "Continue reading →" link)

Why wont ItemDescription acll the image?
View user's profile
webfeatus



Joined: 12 May 2008
Posts: 23

PostPosted: Tue Jun 12, 2012 9:24 am Reply with quoteBack to top

bump
View user's profile
Tech Support



Joined: 27 Aug 2004
Posts: 2793

PostPosted: Mon Jun 18, 2012 8:11 am Reply with quoteBack to top

I just looked at the source RSS feed (http://www.3dminime-figurines-bobbleheads.com/articles/category/featured/feed/ ), and the description field doesn't include an image.

_________________
Create RSS Feeds
Audio Recording and Editing
View user's profile
webfeatus



Joined: 12 May 2008
Posts: 23

PostPosted: Mon Jun 18, 2012 7:27 pm Reply with quoteBack to top

I do not undderstand. When I go to http://www.3dminime-figurines-bobbleheads.com/articles/category/featured/feed/ I see an image for every post?

But I must use the workaround above to display the image i.e. content encoded
View user's profile
webfeatus



Joined: 12 May 2008
Posts: 23

PostPosted: Thu Jun 21, 2012 7:07 pm Reply with quoteBack to top

Quote:
description field doesn't include an image


I see what you mean. The image is placed in the <content:encoded> section not the <description> section.

Aparently Word Press structures their RSS function in this way.

Does anyone know of a Word Press workaround for this?
View user's profile
Display posts from previous:      
Post new topicReply to topic


 Jump to:   



View next topic
View previous topic


Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme