FeedForAll Forum Index  
 Home  •  FAQ  •   Search   •  Register   •  Profile   •  Log in
 PHP 5.3 fail View next topic
View previous topic
Post new topicReply to topic
Author Message
demz



Joined: 05 Sep 2012
Posts: 9

PostPosted: Wed Sep 05, 2012 3:52 am Reply with quoteBack to top

Hi,

My hoster has upgraded to PHP 5.3 and now the script wont run anymore..
Any ideas?

Greets
View user's profile
demz



Joined: 05 Sep 2012
Posts: 9

PostPosted: Wed Sep 05, 2012 4:38 am Reply with quoteBack to top

[quote="demz"]Hi,

My hoster has upgraded to PHP 5.3 and now the script wont run anymore..
Any ideas?

Greets[/quote]

ERROR LOG FAILS over split() in: FeedForAll_XMLParser.inc.php

Just placed with preg_ infront of it but i then get other errors, any help from tech guys?
View user's profile
Tech Support



Joined: 27 Aug 2004
Posts: 2783

PostPosted: Wed Sep 05, 2012 8:10 am Reply with quoteBack to top

Could you be a little more specific about the errors you're seeing and where you're seeing them?

_________________
Create RSS Feeds
Audio Recording and Editing
View user's profile
demz



Joined: 05 Sep 2012
Posts: 9

PostPosted: Thu Sep 06, 2012 3:53 pm Reply with quoteBack to top

Hi,

I downloaded the new FeedForAll_XMLParser.inc.php from the sql2html file with should contain the fix for 5.3 but now it seems to do only a few of my sql feeds.. some have syntax XML errors.. while the feeds havent changed..

Is this FeedForAll_XMLParser.inc.php from the sql2html the good file to use?
View user's profile
Tech Support



Joined: 27 Aug 2004
Posts: 2783

PostPosted: Thu Sep 06, 2012 4:05 pm Reply with quoteBack to top

Yes, the FeedForAll_XMLParser.inc.php from the most recent sql2html download is the appropriate one to use but, again, could you be a little more specific? What syntax errors are you seeing and where? What SQL feeds are being parsed and which aren't?

_________________
Create RSS Feeds
Audio Recording and Editing
View user's profile
demz



Joined: 05 Sep 2012
Posts: 9

PostPosted: Thu Sep 06, 2012 4:11 pm Reply with quoteBack to top

updateFeed(1)
updateFeed(3)
$errorCode = 76
xml_error_string() = Mismatched tag
xml_get_current_line_number() = 11
xml_get_current_column_number() = 8
xml_get_current_byte_index() = 770
View user's profile
demz



Joined: 05 Sep 2012
Posts: 9

PostPosted: Thu Sep 06, 2012 4:11 pm Reply with quoteBack to top

And this takes ages to be shown.. database does not update..
View user's profile
demz



Joined: 05 Sep 2012
Posts: 9

PostPosted: Thu Sep 06, 2012 4:25 pm Reply with quoteBack to top

I almost thought i got it...

http://www.feedforall.com/forum/viewtopic.php?t=5674&highlight=errorcode+76

But no :(

Now im getting this:
updateFeed(1)
updateFeed(7)
updateFeed(8)
updateFeed(10)
MySQL server has gone away
MySQL server has gone away
MySQL server has gone away
MySQL server has gone away
MySQL server has gone away
MySQL server has gone away
MySQL server has gone away
MySQL server has gone away
MySQL server has gone away
MySQL server has gone away
MySQL server has gone away
MySQL server has gone away
View user's profile
Tech Support



Joined: 27 Aug 2004
Posts: 2783

PostPosted: Mon Sep 10, 2012 10:37 am Reply with quoteBack to top

Do you know how long the script runs for before the 'gone away' message starts to show up?

The reason I ask is that some hosts have a short limit on the length of time that a database connection can be kept alive.

Also, what you may want to do is change the order of the feeds in your config file to see if it always fails on the same feed or if it fails for all feeds. That may help narrow down where the problem is coming from.

_________________
Create RSS Feeds
Audio Recording and Editing
View user's profile
demz



Joined: 05 Sep 2012
Posts: 9

PostPosted: Thu Sep 27, 2012 3:02 am Reply with quoteBack to top

Worked out fine :)
View user's profile
Display posts from previous:      
Post new topicReply to topic


 Jump to:   



View next topic
View previous topic


Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme