FeedForAll Forum Index  
 Home  •  FAQ  •   Search   •  Register   •  Profile   •  Log in
 Ezine Feed View next topic
View previous topic
Post new topicReply to topic
Author Message
webfeatus



Joined: 12 May 2008
Posts: 23

PostPosted: Mon Jan 28, 2013 9:11 pm Reply with quoteBack to top

I am involved in a support discussion with EzineArticles.com Support.
Regarding this example:
http://www.villanalinabali.com/resources/villa-rental.html
I have explained that this feed has a display error in IE v9:
http://feeds.ezinearticles.com/category/Travel-and-Leisure:Vacation-Rentals.xml The feed displays in FF and I have snt them screenshots.

Are you able to understand what is going on here?
View user's profile
Tech Support



Joined: 27 Aug 2004
Posts: 2783

PostPosted: Tue Jan 29, 2013 8:36 am Reply with quoteBack to top

There is an error within the feed:

XML parsing error: Line 652, character 189: not well-formed (invalid token)

Here's line 652

<description><![CDATA[If you've been to Boracay more times than you can count on your fingers, and you all you know are the 3 main boat stations of the island, then it's time you know more. Read here to learn the newest offering in this famous Philippine island.]]></description>

Character 189 is the R in Read.

FireFox can handle it no problem and so can the other feed readers I tested but IE9 can't, it seems. If you modify that line to remove the hyperlink in the description, it should take care of the error.

_________________
Create RSS Feeds
Audio Recording and Editing
View user's profile
webfeatus



Joined: 12 May 2008
Posts: 23

PostPosted: Tue Jan 29, 2013 8:54 am Reply with quoteBack to top

I will include a link to this forum topic in my next communication with Ezine Support.
Meanwhile, how do I "modify that line to remove the hyperlink in the description" so it takes care of the error in this output in IEv9?
http://www.villanalinabali.com/resources/villa-rental.html
(see RSS feed at bottom of page)
View user's profile
Tech Support



Joined: 27 Aug 2004
Posts: 2783

PostPosted: Tue Jan 29, 2013 10:11 am Reply with quoteBack to top

Actually, I misspoke earlier, it isn't a hyyperlink issue.

The errocode being generated is:

$errorCode = 9
xml_error_string() = Invalid character
xml_get_current_line_number() = 645
xml_get_current_column_number() = 23
xml_get_current_byte_index() = 52705

Now, normally that error only really pops up if either the hosting webpage or the feed are in ISO instead of UTF-8 but I checked the encoding on both and they're both set to UTF-8. So, after digging a bit, I discovered that it's complaining about a smart quote symbol in the feed, which is also what's causing IE9 to not display the feed properly.

Now, since the smart quote symbol in the feed is technically a valid UTF-8 symbol, that really shouldn't be causing an error unless the versions of the libraries used to build PHP on your webhost are outdated.

So, two things:

1) Check with your webhost to make sure that the PHP libraries are up to date.

2) Do you have any control over the original feed itself or are you just translating the content?

_________________
Create RSS Feeds
Audio Recording and Editing
View user's profile
webfeatus



Joined: 12 May 2008
Posts: 23

PostPosted: Tue Jan 29, 2013 10:38 am Reply with quoteBack to top

Just calling the ezine feed; no control.
I am in the process of upgrading php on the server but that may take some time - a glitch with zend optimizer/guard (5.3)

But I cannot see how that will assist with the basic issue:
http://feeds.ezinearticles.com/category/Travel-and-Leisure:Vacation-Rentals.xml does not display in IEv9
View user's profile
Tech Support



Joined: 27 Aug 2004
Posts: 2783

PostPosted: Tue Jan 29, 2013 11:00 am Reply with quoteBack to top

Oh, right... no, that won't directly effect the feed not displaying properly in IE9. Unfortunately, since you have no direct control over the feed, you can't really make any modifications to it and can't change how it's output. There's not really anything you can do directly on your end to make the feed display properly in IE9 because you can't modify the feed.

_________________
Create RSS Feeds
Audio Recording and Editing
View user's profile
webfeatus



Joined: 12 May 2008
Posts: 23

PostPosted: Wed Jan 30, 2013 2:42 pm Reply with quoteBack to top

I will let you know what ezine support say.

Meanwhile, I have just upgraded php & mysql
PHP Version: 5.3.21
MYSQL Version: 5.5.29-cll


Deprecated: Function split() is deprecated in /var/www/vhosts/villanalinabali.com/httpdocs/resources/rss/xmlparser.inc.php on line 260

Fatal error: Call to undefined method baseParserClass::baseParserClassWithExtensions() in /var/www/vhosts/villanalinabali.com/httpdocs/resources/rss/xmlparser.inc.php on line 1693

Seen at: http://www.villanalinabali.com/resources/resources.html
View user's profile
Tech Support



Joined: 27 Aug 2004
Posts: 2783

PostPosted: Thu Jan 31, 2013 11:49 am Reply with quoteBack to top

Based on that error, it looks like you're using an old version of the rss2html script. We stopped using split a while back because it wasn't supported by PHP anymore. So, all you have to do is download the latest script and replace your existing one and that error should go away.

_________________
Create RSS Feeds
Audio Recording and Editing
View user's profile
webfeatus



Joined: 12 May 2008
Posts: 23

PostPosted: Fri Feb 01, 2013 1:08 pm Reply with quoteBack to top

Updated script.
Still an issue.
(in example url above)

$XMLFILE = "http://www.articlesbase.com/rss/categories/788";
$TEMPLATE = "rss2template.htm";
$MAXITEMS = "7";
$NOFUTUREITEMS = "1";
include("rss2html.php");
View user's profile
Tech Support



Joined: 27 Aug 2004
Posts: 2783

PostPosted: Fri Feb 01, 2013 2:03 pm Reply with quoteBack to top

What is the full URL to the template you're using?

_________________
Create RSS Feeds
Audio Recording and Editing
View user's profile
webfeatus



Joined: 12 May 2008
Posts: 23

PostPosted: Fri Feb 01, 2013 6:51 pm Reply with quoteBack to top

http://www.villanalinabali.com/resources/rss2template.htm
View user's profile
webfeatus



Joined: 12 May 2008
Posts: 23

PostPosted: Wed Feb 06, 2013 9:16 pm Reply with quoteBack to top

[quote="Tech Support"]What is the full URL to the template you're using?[/quote]

http://www.villanalinabali.com/resources/rss2template.htm
View user's profile
Tech Support



Joined: 27 Aug 2004
Posts: 2783

PostPosted: Thu Feb 07, 2013 9:06 am Reply with quoteBack to top

Okay, what you're running in to is that you need to use the full URL to the template rather than just referencing the template name in the $TEMPLATE variable. Using a test copy of the rss2html.php script on my web server with the full URL to your feed and template, I can get it to output results. So, updating that variable with the full URL should fix the output issue for your site.

_________________
Create RSS Feeds
Audio Recording and Editing
View user's profile
webfeatus



Joined: 12 May 2008
Posts: 23

PostPosted: Thu Feb 07, 2013 10:09 am Reply with quoteBack to top

OK. I will try that. Thank you.

Meanwhile...

I had a reply from Ezine Support.

Quote:
Thank you for your reply.

This feed has now been fixed. Please let us know if you encounter any
further issues or errors with this feed.


Thank you,
Jenna
http://EzineArticles.com
View user's profile
Display posts from previous:      
Post new topicReply to topic


 Jump to:   



View next topic
View previous topic


Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme