FeedForAll Forum Index  
 Home  •  FAQ  •   Search   •  Register   •  Profile   •  Log in
 RSS Feed beginner View next topic
View previous topic
Post new topicReply to topic
Author Message
garynorris88



Joined: 28 May 2013
Posts: 9
Location: houston tx

PostPosted: Tue May 28, 2013 11:51 am Reply with quoteBack to top

This is my first time trying to implement RSS Feeds to a site. I am quite confused on where to begin. I have given the correct information for ftp and password but when I publish it, it fails. It also doesn't allow me to create a new folder for the feeds. Any help would be GREALY appreciated!
View user's profile
Tech Support



Joined: 27 Aug 2004
Posts: 2783

PostPosted: Tue May 28, 2013 12:04 pm Reply with quoteBack to top

Can you post the FTP log from the program so we can see what the issue with the upload might be?

_________________
Create RSS Feeds
Audio Recording and Editing
View user's profile
garynorris88



Joined: 28 May 2013
Posts: 9
Location: houston tx

PostPosted: Tue May 28, 2013 12:06 pm Reply with quoteBack to top

FTP SERVER: c79.5c0.myftpupload.com
USERNAME: goaldoctor
======================================

======================================
REMOTE PATH:
REMOTE FILENAME: TheGoalDoctor.com.xml
======================================

* Closing connection #0
* About to connect() to c79.5c0.myftpupload.com port 21
* Trying 50.62.228.190... * connected
* Connected to c79.5c0.myftpupload.com (50.62.228.190) port 21
< 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
< 220-You are user number 11 of 500 allowed.
< 220-Local time is now 09:51. Server port: 21.
< 220-This is a private system - No anonymous login
< 220 You will be disconnected after 3 minutes of inactivity.
> AUTH SSL
< 500 This security scheme is not implemented
> AUTH TLS
< 234 AUTH TLS OK.
* successfully set certificate verify locations:
* CAfile: /Applications/FeedForAll.app/Contents/Resources/ca-bundle.crt
CApath: none
* SSLv2, Client hello (1):
* SSLv3, TLS handshake, Server hello (2):
* SSLv3, TLS handshake, CERT (11):
* SSLv3, TLS alert, Server hello (2):
* SSL certificate problem, verify that the CA cert is OK. Details:
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
* Closing connection #0



SUMMARY OF PUBLISHING RESULTS:
==============================
Feed: Publish failed with reason "SSL certificate problem, verify that the CA cert is OK. Details:
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed"[/img]
View user's profile
Tech Support



Joined: 27 Aug 2004
Posts: 2783

PostPosted: Tue May 28, 2013 12:09 pm Reply with quoteBack to top

You may want to show this to your webmaster or whoever maintains/runs your web server. There's an SSL certificate failure during the upload process that's causing the issue but you'll need to ask your web admin how to resolve that.

_________________
Create RSS Feeds
Audio Recording and Editing
View user's profile
garynorris88



Joined: 28 May 2013
Posts: 9
Location: houston tx

PostPosted: Tue May 28, 2013 12:53 pm Reply with quoteBack to top

I would be the web developer for this site and I have the SSL certificate. What would you recommend I do to fix this problem?
View user's profile
Tech Support



Joined: 27 Aug 2004
Posts: 2783

PostPosted: Wed May 29, 2013 9:42 am Reply with quoteBack to top

When setting up the Publishing Site in FeedForAll, for the Protocol field, try choosing Standard FTP instead of Secure FTP

_________________
Create RSS Feeds
Audio Recording and Editing
View user's profile
garynorris88



Joined: 28 May 2013
Posts: 9
Location: houston tx

PostPosted: Wed May 29, 2013 10:05 am Reply with quoteBack to top

I have tried that already unfortunately to no prevail. :(
View user's profile
Tech Support



Joined: 27 Aug 2004
Posts: 2783

PostPosted: Wed May 29, 2013 12:10 pm Reply with quoteBack to top

Can you post what the log says when you try publishing with the Protocol set to Standard FTP?

Thanks

_________________
Create RSS Feeds
Audio Recording and Editing
View user's profile
garynorris88



Joined: 28 May 2013
Posts: 9
Location: houston tx

PostPosted: Wed May 29, 2013 12:12 pm Reply with quoteBack to top

======================================
FeedForAll Mac v2.1 (2.1.0.1)
======================================
FTP SERVER: c79.5c0.myftpupload.com
USERNAME: THEGOALDOCTOR.COM
======================================

======================================
REMOTE PATH:
REMOTE FILENAME: TheGoalDoctor.com.xml
======================================

* About to connect() to c79.5c0.myftpupload.com port 21
* Trying 50.62.228.190... * connected
* Connected to c79.5c0.myftpupload.com (50.62.228.190) port 21
< 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
< 220-You are user number 6 of 500 allowed.
< 220-Local time is now 10:11. Server port: 21.
< 220-This is a private system - No anonymous login
< 220 You will be disconnected after 3 minutes of inactivity.
> USER THEGOALDOCTOR.COM
< 331 User THEGOALDOCTOR.COM OK. Password required
> PASS ********
< 530 Login authentication failed
* Access denied: 530
* Closing connection #0



SUMMARY OF PUBLISHING RESULTS:
==============================
Feed: Publish failed with reason "Access denied: 530"
View user's profile
Tech Support



Joined: 27 Aug 2004
Posts: 2783

PostPosted: Wed May 29, 2013 12:24 pm Reply with quoteBack to top

Best I can tell from that log is that the FTP server doesn't like the password you are using.

Try sending a copy of this log to your hosting company and inquire what is wrong, or what password you should be using for that to work.

_________________
Create RSS Feeds
Audio Recording and Editing
View user's profile
garynorris88



Joined: 28 May 2013
Posts: 9
Location: houston tx

PostPosted: Wed May 29, 2013 1:33 pm Reply with quoteBack to top

So I checked with hosting. It shows that the file I created using Feedforall was successful, it even uploaded the xml file just not into the specified folder. Although the xml file was 0kb. So I believe it's getting into account it just fails every time I try it. Very frustrating because I know it is something simple that I just don't know about.
View user's profile
Tech Support



Joined: 27 Aug 2004
Posts: 2783

PostPosted: Wed May 29, 2013 2:19 pm Reply with quoteBack to top

Can you post a log where it successfully put the file up on the host, but in the wrong folder, because that last log shows that FFA couldn't even log into the FTP server.

_________________
Create RSS Feeds
Audio Recording and Editing
View user's profile
garynorris88



Joined: 28 May 2013
Posts: 9
Location: houston tx

PostPosted: Thu May 30, 2013 9:23 am Reply with quoteBack to top

So I have been given a different reason why it won't work. Any thoughts?

======================================
FeedForAll Mac v2.1 (2.1.0.1)
======================================
FTP SERVER: c79.5c0.myftpupload.com
USERNAME: goaldoctor
======================================

======================================
REMOTE PATH:
REMOTE FILENAME: TheGoalDoctor.com.xml
======================================

* About to connect() to c79.5c0.myftpupload.com port 21
* Trying 50.62.228.190... * connected
* Connected to c79.5c0.myftpupload.com (50.62.228.190) port 21
< 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
< 220-You are user number 11 of 500 allowed.
< 220-Local time is now 07:22. Server port: 21.
< 220-This is a private system - No anonymous login
< 220 You will be disconnected after 3 minutes of inactivity.
> USER goaldoctor
< 331 User goaldoctor OK. Password required
> PASS ********
< 230 OK. Current restricted directory is /
> PWD
< 257 "/" is your current location
* Entry path is '/'
> PORT 192,168,1,145,195,39
< 200 PORT command successful
* Connect data stream actively
> TYPE I
< 200 TYPE is now 8-bit binary
> STOR TheGoalDoctor.com.xml
< 425 Could not open data connection to port 1942: Connection refused
* Failed FTP upload: 425
* Remembering we are in dir /
* Uploaded unaligned file size (0 out of 1244 bytes)
* Connection #0 to host c79.5c0.myftpupload.com left intact



SUMMARY OF PUBLISHING RESULTS:
==============================
Feed: Publish failed with reason "Failed FTP upload: 425"
View user's profile
Tech Support



Joined: 27 Aug 2004
Posts: 2783

PostPosted: Thu May 30, 2013 9:38 am Reply with quoteBack to top

I think your feed path is the problem now. It probably shouldn't be blank.

_________________
Create RSS Feeds
Audio Recording and Editing
View user's profile
garynorris88



Joined: 28 May 2013
Posts: 9
Location: houston tx

PostPosted: Thu May 30, 2013 9:41 am Reply with quoteBack to top

When I try to create a path it fails everytime. At least it says it fails but when I go to check my site files, I see the folder I created in there, it's just blank.
View user's profile
Display posts from previous:      
Post new topicReply to topic


 Jump to:   



View next topic
View previous topic


Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme