FeedForAll Forum Index  
 Home  •  FAQ  •   Search   •  Register   •  Profile   •  Log in
 new rss user View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.This topic is locked: you cannot edit posts or make replies.
Author Message
leeanne



Joined: 07 Jul 2007
Posts: 10

PostPosted: Fri Jul 13, 2007 11:15 pm Reply with quoteBack to top

I am using the feedforall, used the tutorial to make the feed, and the items, and saved them to my server. When I tried to add my feed url to itunes it came back saying it was a bad url. My url is http://mywebsitename.com/rss/episode-podcast.html.

In my rss folder I put the xml folder and all the m4v items i want to podcast on itunes. I put the info about the items on my html page, but i'm not sure how they are supposed to link to the xml page. Do i just describe my items and then link them to the xml page?

I'm lost. This isnt as easy as they promised.

Lee-Anne
View user's profile
MacSupport



Joined: 24 Feb 2005
Posts: 2805

PostPosted: Sat Jul 14, 2007 6:16 am Reply with quoteBack to top

leeanne wrote:
I am using the feedforall, used the tutorial to make the feed, and the items, and saved them to my server. When I tried to add my feed url to itunes it came back saying it was a bad url. My url is http://mywebsitename.com/rss/episode-podcast.html.

In my rss folder I put the xml folder and all the m4v items i want to podcast on itunes. I put the info about the items on my html page, but i'm not sure how they are supposed to link to the xml page. Do i just describe my items and then link them to the xml page?

I'm lost. This isnt as easy as they promised.

Lee-Anne


When you posted your feed it should be a .xml file. It is that .xml file that you give to iTunes.

Jim

_________________
Be sure to check out the FeedForAll Mac tutorials at: http://www.FeedForAll.com/tutorials/

FeedForAll Mac and rss2html.php
support@FeedForAll.com
View user's profileVisit poster's website
leeanne



Joined: 07 Jul 2007
Posts: 10

PostPosted: Sat Jul 14, 2007 7:03 am Reply with quoteBack to top

so then I changed my url to my xml file, so now my url says http://www.mysitename.com/rss/myfeedname.xml and when i tested it in itunes it says my items cannot be found on my server, but they are there clearly on my server. My items urls are http:www.mysitename.com/rss/myitemname.m4v

am i missing a step?
View user's profile
leeanne



Joined: 07 Jul 2007
Posts: 10

PostPosted: Sat Jul 14, 2007 7:04 am Reply with quoteBack to top

i did put the http://www etc in my items url
View user's profile
MacSupport



Joined: 24 Feb 2005
Posts: 2805

PostPosted: Sat Jul 14, 2007 7:18 am Reply with quoteBack to top

leeanne wrote:
so then I changed my url to my xml file, so now my url says http://www.mysitename.com/rss/myfeedname.xml and when i tested it in itunes it says my items cannot be found on my server, but they are there clearly on my server. My items urls are http:www.mysitename.com/rss/myitemname.m4v

am i missing a step?


So if you click on http://www.mysitename.com/rss/myfeedname.xml in a web browser it shows your feed? My guess is that the feed isn't where you think it is on the server.

Jim

_________________
Be sure to check out the FeedForAll Mac tutorials at: http://www.FeedForAll.com/tutorials/

FeedForAll Mac and rss2html.php
support@FeedForAll.com
View user's profileVisit poster's website
leeanne



Joined: 07 Jul 2007
Posts: 10

PostPosted: Sat Jul 14, 2007 10:00 pm Reply with quoteBack to top

So I put http://www.mysitename.com/rss/myfeedname.xml in a web browser and it came up with my feed and all my items. but when i test them in itunes they say the items cannot be found on the server. But they are on my server in my rss folder. I can download the feed but the items do not play.
View user's profile
leeanne



Joined: 07 Jul 2007
Posts: 10

PostPosted: Sat Jul 14, 2007 10:13 pm Reply with quoteBack to top

Also I made the mistake of submitting my feed to itunes before i had tested it.

But I notice that when I go to itunes and subscribe to this feed, the times I have uploaded the episodes have not changed since my original uplaod. Originally they were uploading to the wrong spot, so i manually moved them to the right spot, thinking this would work. I am reuploading my items, making sure they are each uploading to the proper folder on my server.

Should I just resubmit my feed under a new name?
View user's profile
MacSupport



Joined: 24 Feb 2005
Posts: 2805

PostPosted: Mon Jul 16, 2007 5:40 am Reply with quoteBack to top

leeanne wrote:
Also I made the mistake of submitting my feed to itunes before i had tested it.

But I notice that when I go to itunes and subscribe to this feed, the times I have uploaded the episodes have not changed since my original uplaod. Originally they were uploading to the wrong spot, so i manually moved them to the right spot, thinking this would work. I am reuploading my items, making sure they are each uploading to the proper folder on my server.

Should I just resubmit my feed under a new name?


The iTunes servers only check the feeds once every 24 hours, so changes may not show up right away. It might take a little while for them to notice the changes. Anybody that subscribes will get the correct information since users don't download from iTunes, they download the feed directly from you.

Jim

_________________
Be sure to check out the FeedForAll Mac tutorials at: http://www.FeedForAll.com/tutorials/

FeedForAll Mac and rss2html.php
support@FeedForAll.com
View user's profileVisit poster's website
leeanne



Joined: 07 Jul 2007
Posts: 10

PostPosted: Wed Jul 18, 2007 4:56 am Reply with quoteBack to top

i reposted a new feed with an item in it and tried to test it in itunes. It says my item cannot be found on the server. Is it a problem that I am putting it in a folder inside my wwwroot folder on my remote site?
View user's profile
MacSupport



Joined: 24 Feb 2005
Posts: 2805

PostPosted: Wed Jul 18, 2007 6:41 am Reply with quoteBack to top

leeanne wrote:
i reposted a new feed with an item in it and tried to test it in itunes. It says my item cannot be found on the server. Is it a problem that I am putting it in a folder inside my wwwroot folder on my remote site?


It could be that. It could be that it is not where you think it is. It could be there are capital letters in the file name and you are using all lower case. I just can't tell from here.

Jim

_________________
Be sure to check out the FeedForAll Mac tutorials at: http://www.FeedForAll.com/tutorials/

FeedForAll Mac and rss2html.php
support@FeedForAll.com
View user's profileVisit poster's website
Display posts from previous:      
This forum is locked: you cannot post, reply to, or edit topics.This topic is locked: you cannot edit posts or make replies.


 Jump to:   



View next topic
View previous topic


Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme