FeedForAll Forum Index  
 Home  •  FAQ  •   Search   •  Register   •  Profile   •  Log in
 fatal error: call to undefined function... View next topic
View previous topic
Post new topicReply to topic
Author Message
fdg123



Joined: 07 Feb 2010
Posts: 9
Location: CA

PostPosted: Mon Feb 08, 2010 12:13 am Reply with quoteBack to top

hi,
I have set up separate page to run news feeds and I get this:

Fatal error: Call to undefined function FeedForAll_scripts_readFile() in /home/content/83/5074083/html/rss2html.php on line 768

I uploaded latest version (3.0) and still crashes. google rss link was generated on your rss tool page and tested and seems to work. I put both the php file and html template(your sample) page on my root directory to keep simple.
the link to my news feed page is at:
www.vending-la.com/vending-machine-repair-forum
(it says click here for industry news...)
the link I used was generated by your rss tool page.

please help I am not able to debug php script.

fdg123
View user's profileVisit poster's website
fdg123



Joined: 07 Feb 2010
Posts: 9
Location: CA

PostPosted: Wed Feb 10, 2010 10:28 pm Reply with quoteBack to top

Hi,
I went back to buildURL and double checked all my cut and pastes. All exactly as the examples.
It says xmlfile successfully opened.
It says template file sucessfully opened.
BUT when I click on the test link itcrashes!
With the following errors:

$errorCode = 76
xml_error_string() = Mismatched tag
xml_get_current_line_number() = 4
xml_get_current_column_number() = 47
xml_get_current_byte_index() = 183

WHATS UP! If YOUR OWN build URL page says links are opened successfully and then YOUR OWN test link fails? HMM?

FRANK
View user's profileVisit poster's website
fdg123



Joined: 07 Feb 2010
Posts: 9
Location: CA

PostPosted: Sat Feb 13, 2010 1:30 am Reply with quoteBack to top

well,
I gave up on google news and tried an rss link to yahoo news.
This time the test link worked! Yaaa!
However, when i run it on my website I get the same "Fatal Error in.......768.
I used the encoded links from the buildURL tool.
Double checked my cuts and pastes.
IF any body can help me, please do.
FRANK
View user's profileVisit poster's website
fdg123



Joined: 07 Feb 2010
Posts: 9
Location: CA

PostPosted: Fri Feb 26, 2010 11:58 pm Reply with quoteBack to top

YOU HAVE TO UPLOAD THE PARSER PHP PROGRAM AS WELL!
It would be NICE if your documentation said that. It says to upload rss2html.php, BUT NO WHERE does it mention that you need to upload the parser program also. your program works bug free now (as far as I can tell).
Therefore: rated (A) for program funtionality, (D--) for documentation.

FRANK
View user's profileVisit poster's website
Display posts from previous:      
Post new topicReply to topic


 Jump to:   



View next topic
View previous topic


Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme